Tools and Functions

QuickTips • Tools & Functions

ExtendSim tools and functions you might not be aware of that might help you with model building.

Connection Lines
Connection linesOne very helpful function is the ability to change the connection line pattern and color. Different types of flows in an item connection and different types of information in a value connection are clearly delineated by changing connection line patterns and colors. You will also find this tool useful when you are debugging the model or explaining it to others.
Right to Left and Left to Right Block Direction
Both Value blocks and Item blocks can change the direction in which they flow: from left to right or right to left. For Value blocks, this can be useful because it can make the connection line cleaner in some instances. The ability to change the direction of Item blocks offers the benefit of showing the flow going in the opposite direction. To change a block's direction, right-click on the block's icon and choose the direction in the popup menu.

Block directionYou may want to construct the model in the same fashion of the actual system as shown in this illustration. A word of caution, some blocks look somewhat similar when you change the direction, so be careful and keep your inputs and outputs straight
ProfilerProfiler
The Profiler should be run on every model at least once towards the end of development. You can turn this on from the Run menu (Run Menu > Model Debugging >Profile Block Code). The Profiler will report the total amount of execution time for every block in the model. If you want your model to run faster, this tool shows you where most of the time is being spent. With the Profiler, you can focus on the blocks that take the most time, which will have the most impact on run time. The Executive block generally shows up fairly high on this list, but the rest of the blocks shouldn’t consume as much execution time. If you see unnecessarily higher execution time in various blocks, there could be issues with how you have constructed it.
Revert ModelRevert Model
The benefit of the Revert function is that it provides you the opportunity to undo a variety of mistakes you might have made throughout the model building process. The File > Revert Model function takes you back to the last saved version of the model utilizing the .bak file.
Status Bar
Status BarAt the end of a run, the Status Bar will report Simulation finished at time xx, how long the simulation run took, and fixed seed if the seed isn't random.
Hidden WindowsHidden Windows
When working with multiple models, if you can't locate an open window or dialog, use the ExtendSim Window command to Tile or Cascade your windows or select from the list to bring the specific window forward.
Find a Block
Find iconUse the Edit > Find command, Control + F, or click the icon in the toolbar to open the Find dialog to locate a block in a model.
Find MeFind a Hierarchical Block
To find a specific hierarchical block's location in a model, use the Find Me button on the hierarchical block's worksheet bar.
Find and ReplaceGlobal Changes to Blocks
Use the Find and Replace block from the Utilities library to make a global change to a specific block type.
Navigator
NavigatorThe Navigator is an explorer-like window that is useful both for navigating through a model’s hierarchical structure and for getting quick access to block dialogs in large models. Click on the Navigator button on the ExtendSim toolbar or choose Window > Navigator from the ExtendSim menu to access it.