Product ID Information

ExtendSim Serial Number:

Product Code:

Maintenance Plan: add within 60 days of purchase
EXTENDSIM 9 REFERENCE

Welcome to ExtendSim 9 and thank you for purchasing the latest release of ExtendSim! This reference provides important information about release 9, guides you through the installation process, and summarizes support resources.

What This Document Covers

1. ExtendSim Documentation
2. System and Hardware Requirements
3. Installation Instructions
4. Upgrading From a Prior Release
5. ExtendSim Resources
6. Support Options
7. Overview of What’s New in ExtendSim 9
8. Summary of Features Added in Release 8
ExtendSim Documentation

There are three ExtendSim manuals:


2. **Developer Reference** – a resource for modelers who use equation-based blocks and for programmers who build or modify ExtendSim blocks and components.

3. **ExtendSim 9 Reference** – this document, which provides the new and enhanced features of release 9, installation instructions, technical support resources, and other helpful information.

The User Guide and Developer Reference are electronic (PDF) files that have been updated for release 9. These electronic files are located in the folder ExtendSim9\Documentation; they are installed with ExtendSim.

Quickly access the User Guide and Developer Reference at any time by giving the command Help > ExtendSim Help. Or open the User Guide by clicking that button on the Quick Start interface that appears when you launch ExtendSim.
System and Hardware Requirements

Central processing unit:
Since simulation is processor-intensive, we recommend that your computer have a powerful central processing unit (CPU). Furthermore, as release 9 does not support multiple processors, fewer cores with faster processing speeds will execute simulations faster than more cores.

Windows specific:
- XP, Vista, Windows 7 or Windows 8
- 300 MB hard disk space (400 MB for ExtendSim Suite)
- 512 MB RAM (2 GB recommended)
- For ExtendSim Suite: a 3D hardware accelerator card with 64+ MB RAM

Macintosh specific:
- OSX 10.4 to 10.6
- A browser to view the Help
- 300 MB hard disk space
- 512 MB RAM (2 GB recommended)

Release 9 is not Lion compatible – it does not run on Mac OS 10.7 or greater. ExtendSim will be compatible with Mac OS 10.7+ in release 10.
Installation Instructions

This information is specific for single-user licenses. Instructions for concurrent-user network licenses are provided separately.

Windows installation

1. If this is an upgrade, first read “Upgrading From a Prior Release” on page 8.

2. Back up your ExtendSim files, especially any custom files – models, libraries, include files, and so forth.

3. Note that the Installer will write some ExtendSim files to one location and some to another:
   a. The ExtendSim application and files that are not meant to be modified, such as the Help, will be installed in the folder Program Files\ExtendSim9.
   b. User-modifiable files (models and libraries), will be installed in a Documents folder.

4. Insert the ExtendSim CD into your hard drive. (If you’ve been given a file instead of the CD, install ExtendSim by clicking the Setup.exe file.)
   a. If AutoRun is enabled, you will see the ExtendSim Installer splash screen. Click the “ExtendSim Install” icon and follow the Installer’s instructions.
   b. If you don’t see the Installer splash screen, AutoRun is not enabled. In this case, locate the Setup.exe file on the CD then launch that file.

5. In the “Installing User Documents” window, choose where the user files (models, libraries, etc.) are installed. Depending on who is doing the installation, the Installer’s default location might not be the correct one.
6. **The end user must have read/write access to the user files, so installation of User Documents should typically be into the Documents folder for the actual end user, such as C:\Documents and Settings\My Documents\ExtendSim9.**

7. Your ExtendSim Serial Number, Product Name, and Product Code are on the front of this document.

8. Register during installation. Or register after using the Register.exe file that is located in the folder Program Files\ExtendSim9\Online Registration.

9. See the After Installation instructions on page 6.

**Macintosh installation**

1. If this is an upgrade, see “Upgrading From a Prior Release” on page 8.

2. Back up your ExtendSim files, especially any custom files – models, libraries, include files, and so forth.

3. ExtendSim 9 is not Lion compatible – it does not run on OS 10.7 or greater. Release 10 will be compatible.

4. Insert the ExtendSim CD into your hard drive.

5. Double-click the “ExtendSim Installer.app” icon.

6. Follow the Installer’s instructions.

7. The ExtendSim Serial Number, Product Name, and Product Code are on the front of this document.

8. Email your Serial Number and contact information to info@ExtendSim.com.

9. See the After Installation instructions on page 6.
After installation

- If you have custom files from a prior release, after installing:
  - Copy your custom models to the \ExtendSim9\Examples folder. (For Windows, these files should be in the My Documents folder.)
  - Copy your custom libraries into the \ExtendSim9\Libraries folder.
  - Copy your custom extensions into the appropriate folders within the \ExtendSim9\Extensions folder.

- Because ExtendSim now supports separate Options files for each release, you may need to restate your preferences. Do this in the Edit > Options menu.

- You may uninstall the previous release of ExtendSim. If you decide to instead keep the earlier ExtendSim release on your computer:
  - Technical support is not provided for older releases.
  - Only one instance of ExtendSim can run at a time.
  - If you launch ExtendSim by double-clicking a model or library file, the most recent release of ExtendSim will open. To cause that process to open a different instance of ExtendSim, use the File > Update Launch Control command.

- Due to architectural and file format changes, once files have been saved in release 9 they cannot be read by older releases. To maintain files for an older release, use the Save As command and either rename the file or save a copy of the file in a different location. The newly saved file can then be used in ExtendSim 9 without overwriting your older file.
If your models have links that were created using the command File > Paste DDE Link, changing the model name and/or location will break the links. Be sure to make a backup copy of any linked models before opening them in ExtendSim 9. Furthermore, as Microsoft considers DDE to be a legacy technology, we suggest you not use DDE for new models.

**Warning regarding legacy files**

- ExtendSim 9 contains certain files, known as Legacy libraries, that were discontinued with ExtendSim 7:
  - Animation library
  - BPR library
  - Discrete Event library
  - Generic library
  - Mfg library
  - Quick Blocks library

- The Legacy libraries have been replaced by the Animation 2D-3D, Item, Rate, Value, and Templates libraries, which provide more functionality and flexibility.

- Legacy files are only supplied in release 9 so that you can open older models and convert them to using the new libraries.

*Do not use any of the Legacy libraries when building or modifying models. Legacy libraries are not supported and will not be shipped in release 10.*
Upgrading From a Prior Release

If you are upgrading from release 8.0.x:

- Release 9 is consistent with the changes made in release 8; there should not be any major upgrade issues.
- Architectural changes cause models and libraries saved in release 9 to be unreadable by earlier releases. For details, see the after-installation information on page 6.
- Don’t use the Legacy libraries (Animation, BPR, Discrete Event, Generic, MFG, and Quick Blocks) to build or modify models – see warning note on page 7.

If you are upgrading from release 7.0.x:

- In addition to the new features of release 9 (page 12), there were many changes in release 8 (page 24).
- A major change in release 7 was the introduction of the Animation 2D-3D, Item, Rate, and Value libraries and an integrated ExtendSim database capability. The libraries and features they replaced were relegated to Legacy status.
- Some Legacy libraries (Animation, BPR, Discrete Event, Generic, MFG, and Quick Blocks) are included in release 9 so you can temporarily run older models and convert them to using the new libraries.
- Other Legacy libraries (Flow, ItemsDB, and SDI Tools), and the Industry database, were discontinued after release 7; they are not included in release 9.
- Don’t use Legacy libraries to build or modify models – see warning note on page 7.
If you are upgrading from a release prior to 7.0:

- Among many other major changes, release 7 introduced the Animation 2D-3D, Item, Rate, and Value libraries as well as an integrated and relational ExtendSim database. The libraries and features they replaced were relegated to Legacy status.

- Some Legacy libraries (Flow, ItemsDB, and SDI Tools), and the Industry database, were discontinued after release 7; they are not included in release 9.

- Other Legacy libraries (Animation, BPR, Discrete Event, Generic, Mfg, and Quick Blocks) are included in release 9 so you can run older models and convert them to using the newer libraries and features.

- The Legacy libraries are not supported and will be discontinued with release 10. Don’t use blocks from the Legacy libraries (Animation, BPR, Discrete Event, Generic, Mfg, and Quick Blocks) to build or modify models – see warning note on page 7.

- Also see “Important Upgrade Information > Upgrading from Extend 6 or Earlier” at http://www.ExtendSim.com/products/purchase/upgrades.html
ExtendSim Resources

- **Getting Started.** The Quick Start interface (Getting Started model) opens when you launch ExtendSim. Use this interface to explore sample models and to view tutorials on building and running models.

- **Online help.** Access the electronic User Guide and Developer Reference by giving the command Help > ExtendSim Help. Use tooltips to identify interface elements. Get usage and dialog item details by clicking a block’s Help button.

- **Web advice.** FAQs are available at www.ExtendSim.com/support/advice/faq.html.

- **Networking.** Links for ExtendSim user forums, networks, and blogs are at www.ExtendSim.com/support/advice/forum.html.

- **Complimentary support.** Get technical assistance for installation issues, basic usage questions, and troubleshooting for up to 60 days after purchasing a new product or upgrade. For continuing support beyond this complimentary period, choose one of the support options described on the next page.
Support Options

For continuing excellent technical assistance, choose one of these two support options.

Maintenance Plan

- To receive ongoing access to our support staff, an ExtendSim Maintenance Plan must be purchased within 60 days of purchasing an ExtendSim product or upgrade.
- Get help with installation issues, basic usage questions, and troubleshooting.
- Receive free upgrades to the latest ExtendSim releases.
- Experience, evaluate, and influence future products and features.

Per-incident Support

- If you do not subscribe to the Maintenance Plan before the end of your 60 day complimentary support, our support staff can be contacted on a per-incident basis.
- Each incident is a discussion and resolution of one issue.
- Purchase per-incident support from our sales staff or through the ExtendSim store at http://www.extendsim.com/store
What's New in ExtendSim 9

As noted below, some features and enhancements only apply to specific operating systems or to certain ExtendSim products – ExtendSim CP, OR, AT, or Suite.

In addition, some advanced features are not available in ExtendSim LT, which is a limited version intended for students.

For a complete list of new and enhanced features and blocks, go to www.ExtendSim.com/products/features/new.html

New application features in release 9

1. Statistics DB report type (all products)
   - Automatically stores the statistical data from each simulation run in an ExtendSim database.
   - Organizes statistics by block type – one table per type of block.

2. Smart connections (OR, AT, and Suite; Item and Rate libraries)
   - Intelligent connection line control when moving blocks around.
   - Bump to connect. When adding a block to a model, bump it into another block from the same library and they will automatically and correctly connect together (Item and Rate libraries).
   - Drop over connection line. Drop a block onto an existing connection line so the block’s input connector is on top of the line. Smart connections will insert the block between the two existing blocks.
3. **ADO (all products; Windows only)**
   - ADO (ActiveX Data Object) allows communication between ExtendSim and the most commonly used external databases.
   - Provides built-in import and export support for Microsoft Access, SQL Server, and MySQL.
   - Faster and easier to use than ODBC. Does not require defining a data source name (DSN) before accessing data.
   - Automatically configures the ExtendSim database when importing and the external database when exporting.
   - Mirrors fields and records between source and destination.

4. **New menu commands (all products)**
   - **Read/Write Index Checking** (Database menu). Gives an error message when a model tries to read or write data using a non-existent or incorrect database address or index. Useful for debugging block code that interfaces with the database.
   - **Smart Connections** (Edit menu>Options>Model tab). If unchecked, turns off the intelligent connection line control discussed in “Smart connections” on page 12.
Enhanced application features in release 9

1. ExtendSim DB Add-In for Excel (AT and Suite; Windows only)
   - Extensively rewritten to take advantage of features introduced in Excel 2007 – ribbon interface, XML-based file format, and 1 million rows/16,000 columns.
   - Completely specify an ExtendSim database in Excel, including parent/child relationships, cell randomization, named distributions, and more. Then export the database for use in ExtendSim models.
   - Database consistency checking is faster plus has expanded capabilities.

2. Enhancements to string attributes (OR, AT, and Suite; Item and Rate libraries)
   - If a change is made to the value of a string attribute, all the blocks that were referencing the old attribute value will now reference the new value.
   - If the index for the value of a string attribute changes (the order of the values for the string attribute change) all the blocks that were referencing that value will be alerted to the change in location.
   - Changes to string attribute values defined in the database are now error checked at the beginning of the run. This provides more freedom to manipulate databases without having to worry about losing critical pieces of information.
   - A new string attribute interface in the Executive allows modelers to make global changes to string values that are referenced in other blocks in the model.
3. Speed improvements (OR, AT, and Suite; Item and Rate libraries)
   - Models with blocks that don’t have Simulate messages now execute faster.
   - Linked list optimization speeds up the performance of Item library queues and the blocks in the Rate library.

4. Other application enhancements (various products)
   - The upper limit of the variable name length for static and local variables has been increased from 63 to 127 characters.
   - Double-clicking the upper left cell of a data table linked to a database goes directly to the database view of that table.
   - The Block Profile reports results even if the simulation ends prematurely.
   - Increased mount nodes on custom 3D objects from 8 to 20.
New blocks and libraries in release 9

1. Item Log Manager (Item library; AT and Suite)
   - Supports item logging and reports for tracking items and their states as they move through the simulation.
   - Creates a log of run results, storing the data in an ExtendSim database; the reports can then be exported to Excel.
   - Allows for customized data collection and report configuration from within ExtendSim.

2. Get(R) and Set(R) (Rate library; AT and Suite)
   - The Set(R) block is for setting value or string flow attributes. The Get(R) block displays either multiple flow attributes from one location or one flow attribute from multiple locations.
   - The Get(R) and Set(R) blocks support the Rate library’s new flow attributes feature.

3. Meter block (Utilities library; all products)
   - Provides more flexibility and features than the Meter control (Model>Controls>Meter).
   - The color and pattern of the indicator change when the current value has reached specified high and low values.
   - The block can be used as a progress bar and can animate a hierarchical block.

4. Templates library (all products)
   - This library contains templates – submodels within hierarchical blocks – for common modeling situations.
   - Discrete event templates include: Activity (cycle-based shutdown), Create (arrivals vary by time), Queue (batch all items), Queue (dump contents), and Queue (random renege).
Enhanced blocks and libraries in release 9

1. Rate library (ExtendSim AT and Suite)
   - Flow attributes – characteristics of the flow such as type, product, color, and so forth – can be associated with each specified volume of flow.
   - Two types of flow attributes are supported: layer and string layer.
   - Each Rate block that holds/provides flow has a Contents tab showing the attribute values of its flow by volume.
   - The Tank provides multiple options for defining how the incoming and outgoing flow should be layered.
   - The Interchange has a matrix for converting item attributes into flow attributes and vice versa.

2. Equation-based blocks (various libraries; all products)
   - Additional input and output variables in most blocks.
   - New checkboxes in the Options tab control the execution of the equation.
   - Equation blocks now support static variables that have been declared in include files.
   - Query Equation (AT and Suite only) has new input variables.

3. Value library (all products)
   - Data Import Export
     - Incorporates the new ADO capability.
     - New option to import named range from Excel spreadsheet.
     - Database field names can be exported to Excel.
When importing from Excel, the number of rows in the database automatically adjust.

- Mean & Variance
  - Collects interval statistics for a specified time period. At the end of the period it reports the calculated statistics, clears the statistics, and begins a new reporting period.
  - Has quantiles so you can see what proportion of the observations fell within an interval.

4. Item library (ExtendSim OR, AT, and Suite)
   - Residence blocks (Activity, Queue, Queue Equation, and Workstation) have variable item input connectors to allow merging of multiple item streams. This works the same as the Select Item In block’s Merge option.
   - Activity
     - Two new value inputs: PC (Processing Cost) allows user to target different processing costs on different items; CPI (Cost Per Item) attaches a unique CPI to each item.
     - A new value output: TE (Total Items Exited).
     - If preempting with items, attributes on the preempting item can be transferred to the preempted item.
   - Executive has variable connectors for events.
   - Gate now allows Shift block to control its behavior.
• History
  o Provides more control over data collection and has new options for handling data storage in multi-run scenarios.
  o A checkbox on the Options tab causes data to be stored in a database table at the end of each run.
• Query Equation (I) (AT and Suite only) adds targeted querying and two new input variables.
• Queue Equation has new input and output variables.
• Queue Matching has new “recipe” building and batching capabilities.
• Read (I) and Write (I) blocks have new options for querying where to read and write data.
• Scenario Manager (AT and Suite only) also supports the optimal design of experiments (DOE) method for Minitab 16, a statistical software product from Minitab Inc.
• Shift allows you to display a symbol on block icons if they use a specific Shift block.
• Shutdown
  o Separate and independent polices can be specified for both Shift and connector-based scheduled shutdowns.
  o Off-shift downs (OFD) connector reports the number of shutdowns due to off shifting.
  o Accumulated off-shift downtime (OST) connector reports the amount of time the block has been down due to off shifting.
The “multiple components” option has new capabilities: the matching feature allows one master failure table to represent multiple failure points in the model; summary failure data for each component; component state and dependency/independency options; and block state versus component state reports.

- Transport has an option to prevent items from passing each other when traveling through the block.
New functions, message handlers, and global variables

In addition to the functions listed below, include files are useful when creating custom blocks. To see a block’s include file, open the block’s structure. Then give the menu command Develop>Open Include Files.

1. The new Modl functions are:
   - blockRect
   - clearUndo
   - DBAddressGetAllIndexes
   - DBDatabaseOpenViewerToTab
   - DBDatabaseTabChangeName
   - DBDatabaseTabDelete
   - DBDataGetCurrentSeed
   - DBDataSetCurrentSeed
   - DBFieldExists
   - DBRecordExists
   - dialogRefresh
   - EquationCompileSetStaticArray
   - fileChoose
   - INetFileImportText
   - INetOpenURL
   - lastSetDialogVariableString
   - whoInvoked
   - WinSetForegroundWindow
2. The new message handlers and global variables are:
   - ModifyRunParameter
   - BlockReceive5-9
   - SysGlobal20-29
   - SysGlobalInt30-59

3. ADO (ActiveX Data Object) functions are used to communicate between ExtendSim and external databases. They are not part of the ExtendSim application but instead are located in the “ADO_DBFunctions v9.h” include file.
   - ADO_Setup
   - ADO_Close
   - ADO_OpenConnection
   - ADO_GetNumTables
   - ADO_GetTables
   - ADO_GetTableColumns
   - ADO_SetTableColumns
   - ADO_AddRecords
   - ADO_SQLServerGetServers
   - ADO_SQLServerGetDatabases
   - ADO_CreateTable
   - ADO_GetFields
   - ADO_GetNumRows
   - ADO_GetNumFields
• ADO_ExecuteNonQuery
• ADO_ExecuteQuery
• ConvertADODataType
• ConvertExtendSimDataType
• DB_FieldGetTypeString
• ADO_CheckCompatableFieldType
Smart Blocks

- Right-click on the output connector of an Item or Rate library block and this feature will pop up a list of the suggested blocks to connect to.
- Smart Blocks use ExtendSim scripting functionality and an adaptive learning algorithm to seamlessly generate and continuously update the list of suggested blocks based on how you model.

New blocks

- History(R) - Rate library
  Records a history of rate values over time.

- Model Compare - Utilities library
  Compares model results before and after running a model.

Enhanced blocks

- Real Timer - Utilities library
  Analyze model performance using the block profiling capability added to the Real Timer block.

- Data Import Export - Value library
  Wild Card feature for table and worksheet names in Data Import Export.

Automated test environment

- Simplifies the process of comparing simulation results between two ExtendSim releases — it identifies any differences between models that were saved in a previous release and those same models run in the new release.
- Compares simulation results before and after making changes to a model.
- If there is no Results tab, the entire dialog is used.
- Note: Only available on Windows operating systems.

Improved Advanced Resource Management (ARM)

- If an allocated resource goes off shift, and the item it's allocated to is in the Activity, you now have the option to either shut the item down or renge it.
Improved Smart Connections

- **Bump to Connect** automatically connects a new block to an existing block and spaces them apart.
- **Auto Insert** inserts a new block between two existing blocks and automatically increases the spacing between them.
- Enable/disable Smart Connections using an option in the Edit > Options > Model tab.

Improved Auto Route Connection Lines

- **Intelligent connection line control** anticipates how you want the connections between Item and Rate connectors to behave when you move blocks.
- Enable/disable Auto Route Connection Lines using an option in the Edit > Options > Model tab.

New/changed options in the Edit>Options>Model tab

- **Auto Route Connection Lines**
- **Smart Connections** (Bump to Connect and Auto Insert)
- Both options only apply to Item & Flow connectors (Item & Rate library blocks)

New and changed functions and message handlers

- **Message handler**
  - **OldFileUpdate** - Sent if the file version is older than the application version
- **Functions**
  - **ProfileBlockGet** - Returns the block profile results for a specified block
  - **GetRunParameter** - Similar to GetRunParameterLong except returns a real rather than an integer
  - **ConArrayGetNthCon2** - Same as ConArrayGetNthCon except it has an additional argument to specify the connector on a different block.
  - **GetBlockTypePosition** - Two new values for Type: 5 (embedded object) and 6 (blockControl)

File format change

- Due to architectural changes in ExtendSim 9.1, files created and saved in 9.1 are not backwards compatible so are not readable by ExtendSim 9.0.

Look for our ExtendSim YouTube video series.

www.YouTube.com/user/ExtendSim
Release 9.2 adds new features and improvements, steps up performance, and solves some customer issues. Main enhancements since Release 9.1 are:

## Improved performance and precision

- **Executive** - Item library
  A new method for reusing deleted item indexes enhances performance for discrete event models.

- **Data Specs** - Value library
  Modified so it tightly restricts conditions under which an entire database or table can be registered, decreasing runtimes.

- **Read(), Resource Item, Set, & Write()** - Item library
  Improved model runtimes by increasing performance.

- **Interchange** - Rate library
  Enhanced precision.

## Value library

- **Data Specs, Equation, Read, and Write**
  Added right-click ability to automatically add a named connection.

- **Mean & Variance**
  Added first value as the initial value for time weighted statistics.

- **Write**
  Significantly modified and improved exporting to text files.

## Rate library

- **Diverge and Merge**
  Two new options to maintain outflow attribute values - when the inflow effective rate is 0 and when all attribute values are Blank.

- **History(R)**
  Checkbox saves memory by disabling the recording of information during a simulation run.

- **Valve**
  Added a shutdown option, utilization statistics, and pie chart animation option. Plus info when the quantity and goal quantity had last been calculated and option to ignore a new goal under specific conditions.
ExtendSim 9.2

**Addendum (continued)**

- **Item library**
  - **History**
    - Checkbox saves memory by disabling the recording of information during a simulation run.
  - **Queue Matching**
    - Transfers ARM resources from inbound items to non-preserved batched items.
  - **Transport**
    - The "Do Not Pass" option is now available when the delay is set, not just when speed or speed and distance is selected.

- **Advanced Resource Management (ARM)**
  - **Non-Preserved Batching**: Advanced resources attached to items entering a batching block (Batch and Queue Matching) transfer to the batched item.
  - **Non-Preserved Unbatching**: Advanced resources attached to an item entering the Unbatch or Query Equation() block are now shared equally across all of the unbatched or “spawned” items with a “shared count”.
  - **Non-Redundant Resource Allocation**: If ARM resources are attached to an item as it enters an ARM queue (Queue and Queue Equation), those resources are now used to help satisfy the new allocation requirement wherever possible.
  - **Exclude Resource Release Options**: The Resource Release block has the option to exclude certain resources from release based on that resource’s ability to satisfy one or more specified requirements.
  - New item property **ARM Resource Order ID** in Get, History, and Item Log Manager blocks (Item library).
  - New input variable **AR Order ID** added to equation-based blocks reads an item’s advanced resource order ID.

- **Plotter and Utilities libraries**
  - **Plotter, Discrete Event** has a checkbox to disable the recording of information during a model run to help save memory.
  - **Real Timer** snapshot option creates a profile each time it receives a message.
  - **Model Compare** now has “Ignore blank values in original model” checkbox.
  - **Pause Sim’s Resume option can also initiate a model run. New button runs the model if it is not running, pauses if it is running, and resumes if paused.**

- **New function & message handler**
  - **DLLMakeProcInstanceLibrary** function
  - **BlockSelect** message handler

Look for our ExtendSim YouTube video series.
www.YouTube.com/user/ExtendSim
Summary of Major Features Added in 8.0

1. Equation Editor with tabbing, code colorization, and matching braces
2. Equation Debugger
3. Include files for equations
4. More input and output variable types for equations
5. Scenario Manager for comparing and evaluating a number of model configurations (AT and Suite only)
6. Advanced Resource Management (ARM) system for managing complex resource requirements (AT and Suite)
7. New blocks: Block Info, DBStatistics, Link Alert, Model Interface, MYOB DB Dialogs, Query Equation, Query Equation(I), and Slider
8. New user-requested functions, system variables, and message handlers
9. A “Quick Start” interface for accessing models and tutorials
10. Preloading of libraries
11. Shift-click support
12. New capabilities for reporting and controlling block content
13. Improved ExtendSim DB Add-In for Excel
14. Enhancements to the ExtendSim Database, including a Field Properties dialog and a reserved database feature
15. Improved collision handling and other features in E3D animation

For a complete description of the features added in release 8.0, go to www.ExtendSim.com/products/features/history.html