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The ExtendSim Network License is a concurrent-user license for local and/or wide-area
deployment of the ExtendSim family of products: ExtendSim CP, ExtendSim OR, 
ExtendSim AT, or ExtendSim Suite.

License Manager software is installed on a Server, is TCP/IP based, and runs as a Service.
The ExtendSim application and files are installed on Client computers (Clients use a local installation of
ExtendSim) or on the Server (Client computers access ExtendSim remotely over a network).

The License Manager software must be installed on the Server before the ExtendSim files are installed.

To complete the License Manager installation, you must obtain a License Key. This could impact the installation
process. License Keys are discussed in Step 8 of “License Manager Installation” on page 2. 

After you install the License Manager on the Server, you must choose whether to install ExtendSim on individual
Client computers (typical) or on the Server (atypical). These choices are discussed in the instructions for
“ExtendSim Installation” on page 2.

You cannot install multiple ExtendSim Network Licenses (multiple License Managers) on a single Server.

This Network License is only licensed for installation on one Server. See Note 6 on page 4 for exceptions.

IMPORTANT INFORMATION - before you begin installing

Updating from 8.x to 8.x+

When new non-major releases of ExtendSim occur, Client licenses should be updated; the License Manager on the
Server does not need to be updated. See “Updating Client Licenses” on page 3.

Renewing your Maintenance Plan

When you renew your annual Maintenance, you will receive the “Network Renewal Instructions”.

Upgrading from ExtendSim 7 to ExtendSim 8

See the separate document “*Major Upgrade * Network License” instructions.

UPDATING, RENEWING, AND UPGRADING

Network License Instructions

Licensed To License Administrator Serial Number Product Name & Code

09/11

Windows XP, Vista, 7, 2003 Server, or better. (Run as Administrator for Vista Server installation or removal.)

400 MB hard disk space on Client computers; 5 MB hard disk space on Server.

512 MB RAM – 2 GB RAM recommended.

CD drive for Server installation.

To allow Client access, port 8080 (or another port number if you changed from the default port) must be
unblocked on the Server’s firewall. (To change to a port other than 8080, see Note 1 on page 4.)

For installation of ExtendSim:

ExtendSim Serial Number, Product Name, and Product Code (see top of this page).
Site.tmp file – received by email or located on the ExtendSim License Customization Files CD.
Either the Server’s IP address or its Domain Name.

REQUIREMENTS

This package contains the following:
e ExtendSim Network CD with Server and Client installers
e License Customization Files CD with a Site.tmp file 

(may have been emailed to you)
e ExtendSim manuals

Version

Date Sent



1   Install the License Manager software on a Server before installing ExtendSim on Client computers.
2   If this is an upgrade from ExtendSim 7, first see “Upgrading From An ExtendSim 7 Network License” on page 1.
3   On the Server, insert the ExtendSim Network CD into the Server’s CD drive. (Caution: Remote installation of the 

License Manager is strongly discouraged as the installation may fail. See Note 3 on page 4 for more information.)
4   On the startup screen, click the Server Install button – NOT the ExtendSim Install button. (If the startup screen doesn’t appear, 

run Auto.exe.)
5   Select the destination for installation. See Note 1 on page 4 if you install anywhere other than at the default location

(C:\ExtendSim8Server).
6   Follow the screen instructions to finish the installation. This creates a folder on the Server named ExtendSim8Server.
7   In the ExtendSim8Server folder, launch the application “Setup ExtendSim8 Server.exe” – for Vista, right-click the file and select

Run as Administrator; for others, double-click the file.
8   The License dialog gives a version number and a Reference Code. To proceed, you must obtain a License Key.

Email your ExtendSim Serial Number (from page 1), the version number, and Reference Code to sales@extendsim.com.
Imagine That! will email the License Key to you. NOTE: The License Key response may take up to 72 hours. 
Meanwhile you can click Cancel to close the License dialog, then reopen it once you get the License Key.
See Note 6 on page 4 if you are making a second request for a License Key.

9  Enter the License Key in the appropriate field of the License dialog and click OK. You will receive the following notices:
A “License Key accepted” message.
The IP address of the Server. You will need either that IP address or 
the Server’s Domain Name to install ExtendSim, as discussed below.
A “Server License Manager Installed” message.
A “Server License Manager is running” verification message. 
(See Note 4 on page 4 for how to confirm that the Server License Manager is run-
ning.)

10  Be sure port 8080 (or another port number if you have changed it) is unblocked to allow access to the Server.  
To change to a port other than 8080, see Note 1 on page 4.

1 You must install the License Manager on the Server before installing the ExtendSim files. See above.
2 If this is an upgrade from ExtendSim 7, see “Upgrading From An ExtendSim 7 Network License” on page 1.
3 Before installing the ExtendSim application and files, you need to determine how they will be installed:

On individual Client computers. This is the typical choice.
Or, on the Server such that Client computers launch and use ExtendSim remotely over a network. 
(This is not recommended. ExtendSim performance can be considerably degraded & licenses cannot be checked out.)  

4 Whether you install ExtendSim on a Client or the Server, insert the ExtendSim Network CD into the CD drive. 
5 On the startup screen that appears, click the ExtendSim Install button. (If the startup screen doesn’t appear, run Auto.exe.)

Follow the instructions. NOTE: DO NOT PERFORM THE SERVER INSTALL PROCESS ON CLIENT COMPUTERS!
6 In the User Information dialog, enter user name, company (opt), and ExtendSim Serial Number from the top of page 1. Click OK.
7 On the next dialog, select the Product Name and enter the Product Code – the information is at the top of page 1. Click OK.
8 Network Administrators, note the Installation Locations. If you're installing to a user's account (not to a public or shared 

folder) make sure that the "User Files Location" is for the targeted end user, not for an admin account (i.e. the location should
be "Users/enduser/MyDocuments/ExtendSim8", NOT "Users/admin/MyDocuments/ExtendSim8"). If the user’s account is 
incorrect, Cancel the installation and install correctly. If the user files do get installed to the incorrect location, move the
ExtendSim8 documents folder to the correct location (Users/enduser/MyDocuments/ExtendSim8) after installation. 

9 Choose the “Typical” setup type (the default setting).
10 Select the ExtendSim8 Program Folder (the default setting). 
11  Finish the installation process by following the instructions on the screen.

Clients should not register. The network license is already pre-registered – when prompted to register, 
Clients should instead choose “Finish Later”.
Restarting the computer after installation is optional.

12 Eject the ExtendSim Network CD and insert the ExtendSim License Customization Files CD.
13 Copy the “site.tmp” file from the License Customization Files CD (or the email you received) to the ExtendSim 8 folder 

(\My Documents\ExtendSim8 folder on XP; Vista users copy to \Documents\ExtendSim8).
14 Launch ExtendSim on the Client computer. (The site.tmp file will disappear after launch.)
15 In the dialog that appears, enter the Port (the default is 8080) and EITHER the Domain Name or the IP address of the Server

for the ExtendSim Network License. See Note 1 on page 4 if you want to use a port other than 8080. 
16 Click OK. ExtendSim will launch.
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To temporarily disconnect a Client computer (such as a laptop) from the Server so that the Client computer can use a
network license of ExtendSim from a non-networked position:

1   On the Client, choose the ExtendSim command File > Network License > Check Out License.
2  Then physically disconnect the Client computer from the network. 
Note: Licenses that have been checked out are listed in the Log file as “Checked Out”. (See Note 5 on Page 4.)

Caution: ExtendSim cannot be checked out if it has been installed on the Server rather than on Client computers.

To return a Client’s checked out license to the Server to restore the Server’s count of available licenses:

1  Reconnect the Client computer to the network.
2  Choose the ExtendSim File > Network License > Check In License command on the Client.
Note: Licenses that have been checked in are listed in the Log file as “Checked In”. (See Note 5 on Page 4.)

CHECKING OUT A LICENSE

CHECKING IN A LICENSE

To permanently remove one or more Client computers so that they can no longer use the ExtendSim Network License:

1  On the Client computer, use the ExtendSim command File > Network License > Remove License. 
2  Then, uninstall the program and files from the Client computer using Windows’ Add/Remove Programs control.

To remove the ENTIRE Network License (for instance, so you can install it on another Server):

1  Return any Client licenses that have temporarily been checked out. (This needs to be done on each Client computer 
that has checked out a license; see “Checking In a License”, above.) Then, uninstall Client licenses as above.

2  In the ExtendSimServer folder on the Server, run the “Remove ExtendSim Server.exe” file. You should get two messages:
License Successfully Removed
Service Successfully Removed

3  Use Windows’ Add/Remove Programs to remove the ExtendSim Server Files.
4  Delete the ExtendSimServer folder from the Server.

UNINSTALLING A CLIENT LICENSE

UNINSTALLING THE NETWORK LICENSE

To increase or decrease the number of concurrent users allowed, you must:

1  Uninstall the old Network License Manager from the Server and verify that removal to Imagine That Inc.
2  Install the new Network License Manager on the Server AND obtain a new License Key.
3  Update Client computers that don’t have the current version of ExtendSim and/or a current subscription renewal date.
For more information, see the separate instructions that came with your resized license.

It is important that Client computers use the most recent version of ExtendSim.

1  To determine the installed version, open the Startup screen ( Help > About ExtendSim) on Client computers.
2  To determine the current version, go to http://www.extendsim.com/support_upgrades_ES8.html. (If permitted by

firewalls, the Startup screen will also report if there is a more recent version available.)
3  Download the Update Patch from http://www.extendsim.com/support_upgrades_ES8.html.
4  Install the ExtendSim Update Patch on Client computers following the "ExtendSim Installation" instructions on Page 2.

(Note: It is not necessary to update the Server installation.)

CHANGING THE COUNT OF LICENSES

UPDATING CLIENT LICENSES

Using the ExtendSim Network License
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The ExtendSim Network License is a concurrent-user license that has the following features:

Installs a TCP/IP based License Manager software on a Server
Manages the maximum number of ExtendSim users within a local or wide area network.
Allows users to export or “check out” a license from the network for off-line usage (Client installations only).
Gives information about the number, location, and identity of current Client users. (See Note 5 on page 4.)
Allows you to easily add more users as your simulation needs change.
Includes a Maintenance Plan for updates, upgrades, and technical support, billed at 20% of a new license.
Notifies Client computers when the maintenance renewal date has been reached.

NETWORK LICENSE FEATURES
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1  To install the License Manager into any location other than the default location (C:\ExtendSim8Server) or 
to use a port other than the default port (8080), you must modify the “exServer.ini” file. The exServer.ini file is 
located in the ExtendSim8Server folder.

To change the path to the Server, modify the PP:path field in the command line. This is the path to the 
directory containing the exServer files on the Server. Restart the Server.
To change the port, enter a different number in the port field command line in the exServer.ini file. Be sure the
port is unblocked on the Server to allow access to the License Manager software. Restart the Server.

2  If the Server is in a local area network (LAN) that is using Network Address Translation (NAT), Clients will be restricted
to being in that LAN unless you either:

Establish a Domain Name for the Server and use that Domain Name instead of the IP Address when you install
the Network License on Client computers.
Or, set the Network License up in a different LAN that is not using NAT.

3  It is strongly suggested that you do not install the License Manager remotely onto the Server. Installing remotely,
such as via a terminal service, can provide incorrect machine information to the License Manager. This can cause it
to think the machine you’ve remotely installed from is the intended Server, rather than the machine you’re installing
to. When Client computers then try to connect to the Server, this can lead to file/machine code signature errors. 

4  The License Manager does not have a user interface. To confirm it is running, either:
On the Server, locate the exServer.exe process in the Processes list of Windows Task Manager (CTRL+Alt+Delete). 
Or, launch ExtendSim on a Client computer to verify that it can connect to the Server License Manager.

5  To get information about Network License users:
The number, location, and identity of current users is displayed in each Client computer’s File > Network License
> License Info command. (This does not include information about checked out licenses.)
To determine who has checked out a license, either:

On the Server – look for the “Checked out” log entries in the WANExportLog.txt file.
On the Client – go to File > Network License > License Info and click Checkout List in the 
Network License Information dialog. 

6  The License Manager is licensed for installation on only one Server.  Thus you will normally only be given one License
Key. There may be special reasons why you would request a second License Key: 

If you change the License Manager from one Server to another or change the number of licensed users.
If some failure requires you to uninstall and then reinstall the License Manager on the same Server.
If you performed a test installation of the Network License prior to making the permanent installation.

To obtain a second License Key, you must clearly explain why you want the second License Key and you must verify
that the original Network License has been uninstalled from the Server or that it will not be used except for tests. 
(To uninstall the Network License, see Page 3 of these instructions.) For verification, either:

Email a screenshot of the two messages generated when the Network License is uninstalled, or
Send a signed declaration on company letterhead stating the original Network License will only be used for tests.

NOTES

Notes & Troubleshooting
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1  If a Client has problems connecting to the Server, check the firewall on the Server and unblock port 8080.

2  Signature errors when connecting from the Client to the Server are usually caused because the software was installed
remotely on the Server. See Note 3, above.

3  After entering the License Key, the error message “Reference codes do not match” indicates that the License Key was
not entered properly. Try again.

4  Running the “Setup ExtendSim Server.exe” file after the License Manager has been installed, or running the “Remove
ExtendSim Server.exe” file after it has been uninstalled, will generate error messages. These messages have no
impact on the system and can be ignored.

5  The License Manager is installed as a Service on the Server. To see a list and the status of currently installed Services,
see the \Control Panel\Administrative Tools\Services folder.

6  If a Client computer, which was previously connected to the Server, cannot now find the Server, the Server may be
shut down or the license file may have been moved or deleted. Unless you are uninstalling the entire ExtendSim
Network License, do not move or remove the numbered folder containing the License.sls file from the Server.

TROUBLESHOOTING


